PDA

View Full Version : Controller Problem?



eap9
07-05-2002, 11:18 AM
There is something wrong with my controller. I was using it for a GT12 race and before the end of the straight, I let go of the trigger but the car still went ahead at full power destroying the chassis when it hit the retainer wall.

After the race I took out my grp 7 wing car and after a few laps it did the same thing which also destroyed the car.

The controller in question is a Koford with an external resistor, adjustable brake and choke and full power relay switch. Some of my fellow racers think its the full power relay that is causing the problem which would switch on when you depress thr trigger for max power but would not switch off when you ley go of the trigger?

Any idea?

DifalcoDesign
07-05-2002, 01:00 PM
Eap9, since you have an external the relay is probably triggered by the last band on the wiper block. Most likely the slot between the last two blocks is shorted with brass dust from cleaning as well as dirt. Scrape the slot with an x-acto blade then flush it with lighter fluid and maybe an old tooth brush to get in slot.

I have never had a relay stick closed and it is always the method that turns the relay on that causes the problem. While you are at it you should file the bands flat and clean all the slots.

Are you sure it went in under power or did the brakes not work? Clean brake contacts also.



Jim Difalco
Difalco Design

eap9
07-08-2002, 05:14 AM
Thank you Jim for the help. I will try your suggestion.